Onderwerp


Verwijzen naar de laatste N waarden

Stel dat je een lijst met waarden hebt die elke dag wordt uitgebreid. Kan ik een formule maken die altijd het gemiddelde van de laatste "N" waarden berekent?



Informatie


Er zijn meerdere formules te bedenken voor de oplossingen van dit probleem. Dit voorbeeld maakt gebruik van een drietal functies waar Excel standaard over beschikt.

Het zijn de functies:
- Verschuiving
- Aantal
- Gemiddelde

Met deze drie functies maak je een formule die het beste te begrijpen is als je dit
voorbeeldbestand download.
Het voorbeeld gaat uit van een tabel met tien records. Deze tabel beslaat het bereik B5:F15. In F17 kan ik opgeven uit hoeveel waarden mijn berekening moet bestaan. In F18 voer je de volgende formule in.

=GEMIDDELDE(VERSCHUIVING($C$6;AANTAL(C:C)-F17;0;F17;1))

Deze formule berekent het gemiddelde van een verschoven bereik dat variabel is. Dit werkt als volgt.

De functie VERSCHUIVING bepaalt vanaf het startpunt
(C6), het aantal rijen (AANTAL(C:C)-F17) en kolommen (0), dat het bereik verschoven moet worden, waarbij de omvang van dit bereik bestaat uit een aantal rijen (F17) en kolommen (1)

Het aantal rijen dat het bereik verschoven moet worden, wordt bepaald door de functie
AANTAL. In dit geval telt deze functie alle waarden in kolom C en trekt daar het aantal dat je opgeeft in F17

De functie
GEMIDDELDE berekent vervolgens van het nu bepaalde verschoven bereik het gemiddelde

!! Het resultaat is een uitkomst die altijd het gemiddelde bepaald over het aantal waarden dat je in F17 opgeeft.

!! De Engelstalige variant

De Engelstalige variant van de gebruikte functie is:
=AVERAGE(OFFSET($C$6;COUNT(C:C)-F17;0;F17;1))