Onderwerp


Nul als antwoord bij Vertikaal zoeken

Kan de functie Vert.Zoeken een 0 als antwoord opleveren, als er geen exacte match gevonden wordt ? Dit
voorbeeld toont aan dat dat kan, maar niet zonder dat je deze formule een beetje complexer maakt.


Informatie


Waar het om gaat is dat je de functie Vert.Zoeken op twee manieren kunt gebruiken. Dit komt tot uitdrukking in het vierde argument "Benaderen". Standaard is de waarde voor het vierde argument "Waar", wat betekent dat de eerste waarde, kleiner dan de gezochte waarde, wordt weergegeven als er geen exacte match is.
De functie
Vert.Zoeken zou je op deze wijze dus kunnen gebruiken bij het raadplegen van een belastingschijventabel.

Je kunt de functie echter ook gebruiken om alleen exacte waarden op te zoeken. Het vierde argument in de functie krijgt dan de waarde "Onwaar". Als een exacte match niet bestaat, wordt als antwoord #N/B weergegeven.

Voorbeeld.

De functie
=VERT.ZOEKEN(B17;B6:N15;2;ONWAAR), zoekt in de eerste kolom van tabel B6:N15, naar de waarde uit cel B17. Indien de waarde uit B17 wordt gevonden, wordt de waarde uit de 2e kolom van de tabel weergegeven. Als de waarde in B17 niet wordt gevonden, wordt als antwoord #N/B weergegeven.

De bedoeling is nu om de functie zo aan te passen dat er een 0 verschijnt, als het antwoord van de functie de waarde
#N/B is. De functie wordt dan als volgt:

=ALS(ISNB(VERT.ZOEKEN(B17;B6:N15;2;ONWAAR));0;VERT.ZOEKEN(B17;B6:N15;2;ONWAAR))

De functie
ISNB wordt gebruikt om te testen of de functie als antwoord de waarde #N/B oplevert. Als dat zo is, wordt de waarde 0 getoond. Zo niet, dan wordt het resultaat van de functie Vert.Zoeken getoond.

Wellicht is het beter om de functie zo aan te passen dat er in plaats van een 0, een aantal asterixen wordt getoond. Een nul, wordt in werkbladen immers nog wel eens niet getoond !! De functie wordt dan als volgt:

=ALS(ISNB(VERT.ZOEKEN(B17;B6:N15;2;ONWAAR));"*****";VERT.ZOEKEN(B17;B6:N15;2;ONWAAR)).


!! De Engelstalige variant

De Engelstalige variant van de gebruikte functie is:
=IF(ISNA(VLOOKUP(B17;B6:N15;2;FALSE));"****";VLOOKUP(B17;B6:N15;2;FALSE))