Onderwerp


De Matrix formule




Informatie


Wie eenmaal de kracht van een Matrix formule heeft ontdekt zal ze steeds vaker gebruiken. Een Matrix formule is een formule die werkt met een reeks waarden. Er zijn twee soorten Matrix formules. De eerste levert een resultaat op in een enkele cel. De tweede soort levert een resultaat op in meer dan één cel. Dat resultaat is dus ook een reeks. Deze pagina bespreekt een matrixformule die een resultaat oplevert in een enkele cel.

!! Belangrijk. Een matrixformule voer je in door gelijktijdig op CTRL+SHIFT+ENTER te drukken nadat je de formule in een cel hebt ingevoerd. Doe je dat niet, dan levert de formule een foutwaarde op.



Voorbeeld.

De onderstaande tabel in A1:C6 is een overzicht van de verkoop van groente. Van onderstaande groentemannen wil je weten wat Karel's omzet in Appels was.

Product Verkoper Omzet
Appel Karel € 1200,--
Citroen Sacha € 1000,--
Peer Karel € 1500,--
Appel Karel € 2000,--
Appel Dennis € 1000,--


Indien je dit op de gewone wijze zou uitrekenen zou je eerst een extra kolom opnemen waarin je via een tweetal ALS functies zou bepalen of de omzet betrekking heeft op Karel en op Appels. De antwoorden zou je onder de tabel optellen.
Dit is niet fout, maar wel omslachtig, want met een matrix formule kun je dat in een keer uitrekenen.

Neem de volgende formule over in cel C7.

=SOM((A2:A6="Appel")*(B2:B6="Karel")*(C2:C6))

Voer de formule in als matrixformule door gelijktijdig op
CTRL+SHIFT+ENTER te drukken nadat je de formule cel hebt ingevoerd. Excel zal de functie in de formulebalk automatisch tussen accolades {} plaatsen om aan te geven dat het een matrixformule betreft.

Het antwoord is € 3200,--

!! Het heeft geen zin om een matrixformule in te voeren met accolades en daarna op ENTER te drukken. Excel ziet dit niet als matrixformule.