Onderwerp


De functie Verschuiving




Informatie


De functie Verschuiving geeft een verwijzing naar een cel, of een groep cellen. De verwijzing bevindt zich een aantal rijen omhoog of omlaag en een aantal kolommen naar rechts of naar links, ten opzichte van de cel die als uitgangspunt dient.

De syntax is als volgt:
VERSCHUIVING(Verwijzing;Rijen;Kolommen;[Hoogte];[Breedte])

- Verwijzing
Dit is het uitgangspunt van de functie.

- Rijen
Het aantal rijen dat het bereik verschoven ligt tov het uitgangspunt.

- Kolommen
Het aantal kolommen dat het bereik verschoven ligt tov het uitgangspunt.

- Hoogte [optioneel]
Het aantal rijen dat het verschoven bereik telt.

- Breedte [optioneel]
Het aantal kolommen dat het verschoven bereik telt.



Voorbeelden.

=VERSCHUIVING(A1;3;3)
Deze functie zoekt het bereik dat zich 3 rijen onder en 3 kolommen rechts van A1 bevindt.
Dat is dus cel
D4.

=SOM(VERSCHUIVING(A1;3;3;2;2)).
Deze formule berekent de som van het bereik dat zich 3 rijen onder en 3 kolommen rechts van A1 bevindt. Dit bereik is vervolgens 2 rijen hoog en 2 kolommen breed.
We vinden bereik
D4:E5. Zouden deze 4 cellen met 1 zijn gevuld dan zou het antwoord dus 4 moeten zijn.

Bovenstaande voorbeelden geven aan dat de laatste twee argumenten van de functie zinvol zijn bij sommaties of andere berekeningen. Dit is logisch, want de uitkomst van een formule in een cel, kan nooit een bereik zijn.

Dit is anders bij een benoemd bereik. Je kunt een benoemd bereik invoeren dat chtData heet. Dit bereik wordt berekend door de uitkomst van de functie Verschuiving. De uitkomst van die functie kan best het bereik B5:B25 zijn. Dit mag, aangezien deze waarde in het geheugen van Excel wordt opgeslagen en niet in een cel wordt getoond.


!! De Engelstalige variant

De Engelse termen voor deze functie zijn:
=OFFSET(Reference;Rows;Cols;Height;Width)